Adding OpenStreetMap


I added the open street map but its just filled with light blue. It does not show the as per the example in the exercise.
Need Help Pls.

@Sumbede_Anthoine , off the top of my head, I can think of two possible reasons for this:

  1. Your internet connection is interrupted so the OSM layer hasn’t downloaded properly, or
  2. There’s a problem with the spatial reference system (CRS = Coordinate Reference System as QGIS calls it) either for the project or layers, causing them to misalign.

What happens when you zoom out? Are your layers somewhere in the ocean? That’s how it appears - that colour matches OSM oceans. They should be in northern Vietnam. What happens when you ‘Zoom full’ on the map navigation toolbar, or ‘Zoom to layer’ by right-clicking on the OSM layer?

What CRS is listed in the CRS box (bottom right of your window, not shown in screenshot) - is it 4326? Have you adjusted the project or layer CRSs?

Thanks for your directives Lucy.

After taking a closer look, I found that I missed letter s in writing https:// in the XYZ add later pop up.
Am good now. Already submitted the assignments and also mentioned that there.

Thanks you plenty

1 Like

hello Sumbede, can you please help me? i got stuck on how to add openStreetMap

Please can you let me know at what level you got stock.

Did you see the Add xyz layer in add layer?

i got stuck too , XYP , its nowhere to be found , i guess its because of QGIS version , now trying to upgrade from 2.18.28 to 3.16 at least .

A post was merged into an existing topic: Module 1 assignment: Introduction to GIS/QGIS